CVE-2017-5233
HighSummary
Rapid7 AppSpider Pro installers prior to version 6.14.053 contain a DLL preloading vulnerability, wherein it is possible for the installer to load a malicious DLL located in the current working directory of the installer.
Risk Assessment
This vulnerability could allow malicious code to be executed on the system, posing a significant security risk to the organization.
Recommendation
It is recommended to upgrade to version 6.14.053 or later to mitigate this vulnerability.
Other vulnerabilities in Rapid7 AppSpider Pro
See all- CVE-2017-5236High
Installers of Rapid7 AppSpider Pro prior to version 6.14.060 contain a DLL preloading vulnerability, allowing a malicious DLL located in the current working directory of the installer to be loaded.
- CVE-2025-36857Low
Rapid7 Appspider Pro versions below 7.5.021 suffer from a broken access control vulnerability in the application's configuration file loading mechanism, whereby an attacker can place files in directories belonging to other users or projects. Affected versions allow standard users to add custom configuration files. These files, which are loaded in alphabetical order, can override or change the settings of the original configuration files, creating a security vulnerability. This issue stems from improper directory access management. This vulnerability was remediated in version 7.5.021 of the product.
Original NVD description (English source)
Rapid7 AppSpider Pro installers prior to version 6.14.053 contain a DLL preloading vulnerability, wherein it is possible for the installer to load a malicious DLL located in the current working directory of the installer.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

