CVE Catalog

CVE-2016-20103

HighCVSS 7.5
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.61%

49th percentile - higher than 49% of all known CVEs

Summary

Cherry Plugin for WordPress before 1.2.7 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files via the 'file' parameter in GET requests to /admin/import-export/download-content.php.

Risk Assessment

An attacker can read wp-config.php and other files, exposing database credentials and enabling takeover of the WordPress site.

Recommendation

Upgrade the Cherry Plugin to version 1.2.7 or later and remove or secure the vulnerable download-content.php script.

Related vulnerabilities

Original NVD description (English source)

Cherry Plugin for WordPress before 1.2.7 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files via the 'file' parameter. Attackers can send GET requests to /admin/import-export/download-content.php with traversal sequences like ../../../../../wp-config.php to read database credentials, since the script passes input directly to readfile(). Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS