CVE Catalog

CVE-2016-15052

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.45%

37th percentile - higher than 37% of all known CVEs

Summary

Nagios XI versions prior to 5.2.4 are vulnerable to cross-site scripting (XSS) via the Menu System of the web interface. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Risk Assessment

An attacker could execute arbitrary JavaScript in the browser of a logged-in Nagios XI user, potentially leading to session theft, account takeover, or modification of monitoring configuration.

Recommendation

Update Nagios XI to version 5.2.4 or later. Additionally, consider implementing security headers (CSP) and input filtering.

Other vulnerabilities in Nagios XI

See all
Original NVD description (English source)

Nagios XI versions prior to 5.2.4 are vulnerable to cross-site scripting (XSS) via the Menu System of the web interface. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS