CVE Catalog

CVE-2016-15051

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.42%

35th percentile - higher than 35% of all known CVEs

Summary

Nagios XI versions prior to 5.2.4 are vulnerable to cross-site scripting (XSS) via the Reports interface through values from the startdate and enddate fields. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Risk Assessment

An attacker can execute arbitrary JavaScript in the browser of a logged-in user, potentially leading to session theft or unauthorized actions within the Nagios XI system.

Recommendation

Upgrade Nagios XI to version 5.2.4 or later. Verify that date fields in reports are properly validated after the upgrade.

Other vulnerabilities in Nagios XI

See all
Original NVD description (English source)

Nagios XI versions prior to 5.2.4 are vulnerable to cross-site scripting (XSS) via the Reports interface through values from the startdate and enddate fields. Insufficient validation or escaping of user-supplied input may allow an attacker to inject and execute arbitrary script in the context of a victim's browser.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS