CVE Catalog

CVE-2016-15049

MediumCVSS 5.4
Published: Updated: Translated: NVD NIST

Exploitation Probability (EPSS)

Low risk
0.51%

42th percentile - higher than 42% of all known CVEs

Summary

Nagios Log Server versions prior to 1.4.2 are vulnerable to cross-site scripting (XSS) in the Dashboards section when rendering log entries in the Logs table. Untrusted log content was not safely encoded for the output context, allowing attacker-controlled data present in logs to execute script in the victim's browser within the application origin.

Risk Assessment

An attacker can inject malicious script into logs that executes in the browser of a user viewing the Dashboards section, potentially leading to session theft.

Recommendation

Update Nagios Log Server to version 1.4.2 or later. Until patched, restrict access to the Dashboards section.

Other vulnerabilities in Nagios Log Server

See all
Original NVD description (English source)

Nagios Log Server versions prior to 1.4.2 are vulnerable to cross-site scripting (XSS) in the Dashboards section when rendering log entries in the Logs table. Untrusted log content was not safely encoded for the output context, allowing attacker-controlled data present in logs to execute script in the victim’s browser within the application origin.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS