CVE-2015-9231
HighSummary
iTerm2 3.x before 3.1.1 allows remote attackers to discover passwords by reading DNS queries. A new feature added in version 3.0.0 results in potential information disclosure by sending text as an unencrypted DNS query.
Risk Assessment
Organizations may be exposed to the disclosure of passwords and other sensitive information, potentially leading to serious security breaches.
Recommendation
It is recommended to update iTerm2 to version 3.1.1 or later to mitigate this vulnerability.
Other vulnerabilities in iTerm2
See all- CVE-2026-123014High
iTerm2 before 3.7.7beta2 has an argument injection vulnerability in the x-man-page: URL handler, allowing an attacker to execute arbitrary commands with the privileges of the logged-in user by inducing the user to open a crafted URL. Percent-encoded NUL characters survive input sanitization and are converted to whitespace during command-line parsing, allowing injection of the -P option to select an attacker-controlled pager.
- CVE-2026-88514Medium
An issue in iTerm2 macOS before 3.6.12 allows a local attacker to obtain sensitive information.
Original NVD description (English source)
iTerm2 3.x before 3.1.1 allows remote attackers to discover passwords by reading DNS queries. A new (default) feature was added to iTerm2 version 3.0.0 (and unreleased 2.9.x versions such as 2.9.20150717) that resulted in a potential information disclosure. In an attempt to see whether the text under the cursor (or selected text) was a URL, the text would be sent as an unencrypted DNS query. This has the potential to result in passwords and other sensitive information being sent in cleartext without the user being aware.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

