CVE-2015-3630
HighSummary
Docker Engine before version 1.6.1 uses weak permissions for several system directories, allowing local users to modify the host and obtain sensitive information.
Risk Assessment
An attacker could exploit this vulnerability to perform protocol downgrade attacks and gain access to critical system data.
Recommendation
It is recommended to update Docker Engine to version 1.6.1 or later to mitigate this vulnerability.
Other vulnerabilities in Docker Engine
See all- CVE-2025-54388Medium
In Docker Engine versions 28.2.0 through 28.3.2, reloading the firewalld service removes all iptables rules including those created by Docker. Versions before 28.3.3 fail to recreate the rules blocking external access to containers, so containers with ports published to localhost become accessible from remote machines with routing to the Docker bridge. This is fixed in version 28.3.3.
- CVE-2016-8867High
Docker Engine version 1.12.2 enabled ambient capabilities with misconfigured capability policies. This allowed malicious images to bypass user permissions to access files within the container filesystem or mounted volumes.
- CVE-2026-92543High
Vulnerability in Docker Engine regarding incorrect classification of a registry as insecure. loadInsecureRegistries() injects 127.0.0.0/8 and ::1/128 as insecure CIDRs by default, and isCIDRMatch returns true if any host address matches. An attacker can use a DNS answer with a loopback IP and an attacker IP to disable certificate verification and enable HTTP fallback.
Original NVD description (English source)
Docker Engine before 1.6.1 uses weak permissions for (1) /proc/asound, (2) /proc/timer_stats, (3) /proc/latency_stats, and (4) /proc/fs, which allows local users to modify the host, obtain sensitive information, and perform protocol downgrade attacks via a crafted image.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

