CVE-2015-3250
HighSummary
Apache Directory LDAP API before version 1.0.0-M31 allows attackers to conduct timing attacks via unspecified vectors.
Risk Assessment
Timing attacks may lead to the disclosure of sensitive information, posing a threat to data security within the organization.
Recommendation
It is recommended to upgrade Apache Directory LDAP API to version 1.0.0-M31 or later to mitigate the risks associated with this vulnerability.
Other vulnerabilities in Apache Directory LDAP API
See all- CVE-2026-103877Critical
Deserialization of Untrusted Data vulnerability in Apache Directory LDAP API. A rogue or compromised LDAP server (or a pre-TLS MITM) can answer a client's loadSchema() subschema search with a schema object containing a serialized Java class, potentially allowing RCE. This issue affects versions from 2.1.0 before 2.1.9.
- CVE-2026-103885High
Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API. An LDAP server using the LDAP API (like Apache DS) may consume 100% of a CPU core indefinitely when processing some badly crafted Telephone Numbers. This issue affects versions from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9.
- CVE-2026-103880High
Asymmetric Resource Consumption vulnerability in Apache Directory LDAP API. Storing a password using the bcrypt algorithm with a high force like 30 in an LDAP server that supports this algorithm will cause the server CPU to run for hours checking the credentials. A bounded cost should be enforced to avoid a server DoS. This issue affects versions from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9.
- CVE-2026-103878High
Cleartext transmission of sensitive information vulnerability in Apache Directory LDAP API. A StartTLS extended operation started after a Search request has been sent can lead to receive data in plain text before the TLS Handshake has been completed. This issue affects versions from 2.1.0 before 2.1.9. Users are recommended to upgrade to version 2.1.9.
- CVE-2026-103552High
Stack Overflow vulnerability in Apache Directory LDAP API. Before binding, a client can send a deeply nested search filter that overflows the stack in the server's decoder. This issue affects versions from 1.2.0 before 1.2.9.
- CVE-2026-102731High
Memory allocation with excessive size value vulnerability in Apache Directory LDAP API. A malicious peer (or a MITM) can send a small BER-encoded response causing a large memory allocation before any data is received, leading to OutOfMemoryError and denial of service. This issue affects versions from 1.2.0 before 1.2.9.
Original NVD description (English source)
Apache Directory LDAP API before 1.0.0-M31 allows attackers to conduct timing attacks via unspecified vectors.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

