CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.04)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2025-31160
Medium
—

Wersja atop do 2.11.0 pozwala lokalnym użytkownikom na wywołanie odmowy usługi (np. awaria asercji i zakończenie aplikacji) lub potencjalnie inny nieokreślony wpływ, gdy różni użytkownicy uruchamiają atop oraz nieuprzywilejowane procesy.

CVE-2025-69420
Low
—

W kodzie weryfikacji odpowiedzi TimeStamp występuje podatność typu confusion, w której członek unii ASN1_TYPE jest dostępny bez wcześniejszej walidacji typu. Może to prowadzić do dereferencji nieprawidłowego lub NULL wskaźnika podczas przetwarzania źle sformatowanego pliku odpowiedzi TimeStamp.

CVE-2024-47252
Medium
—

Niewystarczające zabezpieczenie danych dostarczanych przez użytkownika w mod_ssl w Apache HTTP Server 2.4.63 i wcześniejszych wersjach pozwala na wprowadzenie znaków ucieczki do plików dziennika przez nieufnego klienta SSL/TLS w niektórych konfiguracjach.

CVE-2019-6988
Low
—

W OpenJPEG 2.3.0 odkryto problem, który pozwala zdalnym atakującym na wywołanie odmowy usługi poprzez próbę nadmiernej alokacji pamięci w funkcji opj_calloc. Problem ten występuje podczas wywołania z opj_tcd_init_tile.

CVE-2022-1615
Low
—

W Samba, funkcja GnuTLS gnutls_rnd() może zakończyć się niepowodzeniem, co prowadzi do generowania przewidywalnych wartości losowych. To może wpłynąć na bezpieczeństwo aplikacji korzystających z tej funkcji.

GHSA-537c-gmf6-5ccf
High
—

The wheels of pyca/cryptography include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue.

CVE-2019-9543
Low
—

W Poppler 0.74.0 odkryto problem związany z rekurencyjnym wywołaniem funkcji w JBIG2Stream::readGenericBitmap(). Może to zostać wywołane przez wysłanie spreparowanego pliku PDF do binarnego programu pdfseparate, co prowadzi do awarii systemu (błąd segmentacji).

CVE-2023-1386
Low
—

Wykryto lukę w implementacji systemu plików 9p passthrough (9pfs) w QEMU. Gdy lokalny użytkownik w gości zapisuje plik wykonywalny z ustawieniami SUID lub SGID, żadne z tych uprawnień nie są poprawnie usuwane.

CVE-2025-69418
Low
—

Podatność występuje przy bezpośrednim używaniu niskopoziomowego API OCB z AES-NI lub innymi przyspieszonymi sprzętowo ścieżkami kodowymi. Wejścia, których długość nie jest wielokrotnością 16 bajtów, mogą pozostawić ostatni częściowy blok niezaszyfrowany i nieautoryzowany.

CVE-2026-1525
Medium
—

Undici pozwala na duplikowanie nagłówków HTTP Content-Length, gdy są one podawane w tablicy z nazwami o różnych wielkościach liter (np. Content-Length i content-length). To prowadzi do nieprawidłowych żądań HTTP/1.1 z wieloma sprzecznymi wartościami Content-Length.

CVE-2025-68160
Low
—

Podatność polega na możliwości zapisania dużych danych bez nowej linii do łańcucha BIO przy użyciu filtra buforowania linii, co może prowadzić do zapisu poza przydzieloną pamięcią w przypadku, gdy następny BIO wykonuje krótkie zapisy.

CVE-2022-48064
Low
—

W wersjach GNU Binutils przed 2.40 odkryto podatność na nadmierne zużycie pamięci w funkcji bfd_dwarf2_find_nearest_line_with_alt w pliku dwarf2.c. Atakujący może dostarczyć spreparowany plik ELF, co może prowadzić do ataku DNS.

CVE-2024-25269
Low
—

libheif w wersjach do 1.17.6 zawiera wyciek pamięci w funkcji JpegEncoder::Encode. Ta wada umożliwia atakującemu przeprowadzenie ataku typu denial of service.

CVE-2026-31802
High
—

node-tar to pełnoprawne narzędzie Tar dla Node.js. Przed wersją 7.5.11, tar (npm) może być oszukany w celu utworzenia symlinków wskazujących poza katalog ekstrakcji, co umożliwia nadpisywanie plików poza bieżącym katalogiem roboczym.

CVE-2026-1527
Medium
—

Podatność CVE-2026-1527 pozwala atakującemu na wstrzyknięcie sekwencji CRLF ( ) poprzez kontrolowany przez użytkownika input w opcji upgrade metody client.request(). Może to prowadzić do wstrzykiwania dowolnych nagłówków HTTP oraz przedwczesnego zakończenia żądania HTTP, co umożliwia przesyłanie surowych danych do usług nie-HTTP, takich jak Redis, Memcached czy Elasticsearch.

CVE-2024-42516
Medium
—

Podatność CVE-2024-42516 dotyczy rozdzielania odpowiedzi HTTP w rdzeniu serwera Apache HTTP. Atakujący, który może manipulować nagłówkami odpowiedzi Content-Type aplikacji hostowanych lub proxy przez serwer, może rozdzielić odpowiedź HTTP.

CVE-2024-38474
Medium
—

Problem z kodowaniem substytucyjnym w mod_rewrite w Apache HTTP Server 2.4.59 i wcześniejszych wersjach umożliwia atakującemu wykonywanie skryptów w katalogach dozwolonych przez konfigurację, ale niedostępnych bezpośrednio przez jakikolwiek URL, co może prowadzić do ujawnienia skryptów przeznaczonych do wykonywania jako CGI.

CVE-2023-46045
Medium
—

Graphviz w wersjach od 2.36.0 do 9.x przed 10.0.1 ma podatność na odczyt poza przydzielonym zakresem za pomocą spreparowanego pliku config6a. Warto zauważyć, że możliwość wykorzystania tej podatności może być rzadko spotykana, ponieważ plik ten jest zazwyczaj własnością użytkownika root.

CVE-2026-2581
Medium
—

Jest to podatność na niekontrolowane zużycie zasobów (CWE-400), która może prowadzić do ataku typu Denial of Service (DoS). W podatnych wersjach Undici, gdy włączona jest funkcja interceptors.deduplicate(), dane odpowiedzi dla zduplikowanych żądań mogą być gromadzone w pamięci dla dalszych handlerów.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS