CVE Vulnerability Catalog
Translated CVE descriptions from NVD NIST - in English
Browse vulnerabilities by packageCISA KEV catalog updated: (v2026.11.06)
Weekly CVE digest
One email a week with newly published vulnerabilities worth knowing about. No account needed.
This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.
Spring Authorization Server's default consent page renders user-controlled values without HTML entity encoding. An attacker can craft an OAuth2 authorization request containing a malicious value that is stored server-side and later rendered unencoded in the default consent page. Affected versions are 1.5.0-1.5.8 and 1.4.0-1.4.11.
In Spring Integration, an operator who calls JdbcMessageStore.addAllowedPatterns(...) to restrict deserialization receives no protection at all when the store is a Spring-managed bean. Affected versions include 7.1.0, 7.0.0-7.0.5, 6.5.0-6.5.10, and 6.4.0-6.4.12.
Spring for GraphQL's Spring Data pagination support resolves arguments of a scrollable query and forwards the client-supplied values to the underlying repository. An attacker can forge a malicious query for a Connection field that can exhaust application memory or place significant, prolonged load on the underlying datastore, resulting in a Denial of Service. Affects Spring for GraphQL versions 2.0.0-2.0.4, 1.4.0-1.4.6, and 1.2.0-1.3.9.
The GraphiQL page bundled with Spring for GraphQL sends requests to the GraphQL endpoints of the application. An attacker can share a malicious URL so that the victim's browser might leak confidential information to the attacker's website. Affects Spring for GraphQL versions 2.0.0-2.0.4, 1.4.0-1.4.6, 1.1.0-1.3.9, and 1.0.0-1.0.7.
The GraphiQL page bundled with Spring for GraphQL loads JavaScript libraries from a public CDN, without Subresource Integrity checks. An attacker can inject malicious code in those scripts and execute arbitrary code on the browser loading the GraphiQL page. Affects Spring for GraphQL versions 2.0.0-2.0.4, 1.4.0-1.4.6, 1.1.0-1.3.9, and 1.0.0-1.0.7.
Spring for GraphQL applications are vulnerable to Unsafe Deserialization when processing paginated GraphQL queries. Affects versions 2.0.0 - 2.0.4.
In Spring Cloud Commons, there is no allow list for property keys when the writable /actuator/env is enabled. Affected versions include 5.0.0-5.0.2, 4.3.0-4.3.3, 4.0.0-4.2.6, and 3.1.10 and earlier.
Spring Framework applications that use Spring's data binding infrastructure to apply user-supplied property paths onto a target object may be vulnerable to a Denial of Service (DoS) attack.
Silverstripe UserForms, from 6.0.0 until 6.4.9, 7.0.7, and 7.1.1, has a vulnerability in the email recipient subject field. A specially crafted payload can be interpreted as executable server-side code. An authenticated CMS user with permission to configure a UserForms email recipient can run arbitrary code on the server, compromising confidentiality, integrity, and availability. Fixed in versions 6.4.9, 7.0.7, and 7.1.1.
Silverstripe Advanced Workflow, prior to 6.4.5, 7.1.3, and 7.2.1, has a vulnerability in the email template module. An attacker with permission to author email templates can place a specially crafted payload in NotifyUsersWorkflowAction.EmailTemplate, leading to PHP evaluation and arbitrary code execution on the server. Fixed in versions 6.4.5, 7.1.3, and 7.2.1.
Trilium, prior to version 0.104.0, has a vulnerability in the automatic image-download feature. It accepts file:// URLs in img tags and reads the referenced local file with no path validation, allowing any authenticated user to disclose arbitrary files readable by the Trilium process. Additionally, pointing at an unbounded source like /dev/zero causes uncontrolled memory allocation and crashes the server. Fixed in version 0.104.0.
Trilium, prior to version 0.104.0, has a vulnerability in the default-on "Safe import" filter. The filter fails to neutralize the shareTemplate relation because it is not marked as dangerous, allowing an attacker-supplied import archive to plant a server-side template leading to remote code execution. When the victim publishes the imported note, the public share renderer feeds the linked EJS code note's raw bytes into ejs.render, which compiles them in the server's Node process. Fixed in version 0.104.0.
An integer overflow in the SMF component of Open5GS v2.7.6 allows attackers to cause a Denial of Service (DoS) via supplying a crafted GTP packet.
The vulnerability allows arbitrary file write in Veno File Manager 4.4.9. An authenticated user with super administrator role can overwrite any PHP file in the application via a specially crafted POST request to the translations endpoint.
The vulnerability in PentestGPT 1.0.0 in core/langfuse.py allows remote attackers to disclose sensitive user telemetry data via hardcoded API credentials.
An issue in the inviteController.js component in Bluewave Labs Checkmate <=3.3.0 allows remote authenticated administrators to escalate privileges to superadmin via the role parameter to the /api/v1/invite endpoint.
SpeechBrain before 1.1.1 contains an arbitrary code execution vulnerability. Attackers can execute arbitrary code by supplying a crafted CKPT.yaml checkpoint metadata file parsed with PyYAML's unsafe loader during candidate enumeration in Checkpointer.recover_if_possible(). Even if the malicious checkpoint is never selected for recovery, code execution can occur.
Flowintel versions 3.3.0 and later contain an authorization flaw in the administrative user-edit API. An organization administrator could edit a full administrator account within their own organization, including changing its password. The fix adds a higher-privilege boundary check that returns 403 if the user to edit is an admin.
Flowintel versions 3.3.0 and later contain an insecure direct object reference (IDOR) issue across numerous task endpoints. Routes did not enforce that a task belonged to the supplied case, allowing an authenticated user with access to one case to manipulate tasks from another case. The patch adds task_case_bound_required and checks that note_id belongs to the current task.
NLTK versions before 3.10.3 contain a filesystem containment bypass vulnerability in the Downloader.download and Downloader.incr_download methods that allows attackers to overwrite files outside the install root through pre-existing hardlinks. Attackers with write access to a shared downloader directory can create hardlinks pointing to outside-root files that are then overwritten during normal package extraction.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

