CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.04)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2026-3886
High
—

A vulnerability in the virtio-gpu module of the Linux kernel involves an incorrect overflow check when allocating 2D images. This flaw can lead to a buffer overflow, potentially enabling privilege escalation or system crash.

GHSA-f9j4-qggq-h239
High
—

In GitPython, Remote.pull() forwards its positional refspec argument directly to the git pull child process while its unsafe-option guard inspects only keyword arguments. An application that passes attacker-influenced data as the refspec (e.g., a user-supplied branch name) may allow injection of unsafe options.

GHSA-rgj7-g3m4-5g8c
High
—

Several vulnerabilities (two rated critical under CVSSv3) have been discovered and fixed in the upstream libheif dependency. They can lead to remote code execution (RCE) on glibc-based Linux under certain conditions.

CVE-2024-56406
High
—

A heap buffer overflow vulnerability was discovered in Perl. Affected versions include release branches 5.34, 5.36, 5.38, and 5.40, as well as development versions from 5.33.1 through 5.41.10. When non-ASCII bytes are present in the left-hand side of the `tr` operator, `S_do_trans_invmap` can overflow the buffer.

CVE-2025-26519
High
—

musl libc 0.9.13 through 1.2.5 before 1.2.6 has an out-of-bounds write vulnerability when an attacker can trigger iconv conversion of untrusted EUC-KR text to UTF-8.

CVE-2025-52565
High
—

runc is a CLI tool for spawning and running containers according to the OCI specification. Versions 1.0.0-rc3 through 1.2.7, 1.3.0-rc.1 through 1.3.2, and 1.4.0-rc.1 through 1.4.0-rc.2, due to insufficient checks when bind-mounting `/dev/pts/$n` to `/dev/console` inside the container, an attacker can...

CVE-2023-47038
High
—

A vulnerability in Perl 5.30.0 through 5.38.0 allows a heap buffer overflow when compiling a crafted regular expression. An attacker can exploit this to cause a controlled buffer overflow.

GHSA-hrxh-6v49-42gf
High
—

Multiple security vulnerabilities have been identified in the grpc-go library affecting the xDS RBAC authorization engine and the HTTP/2 transport server implementation. These vulnerabilities could lead to authorization bypass (Fail-Open) during rule translation.

CVE-2019-3844
High
—

It was discovered that a systemd service using the DynamicUser property can gain new privileges through the execution of SUID binaries, allowing creation of binaries owned by the service's transient group with the setgid bit set. A local attacker may exploit this flaw to access resources that will be.

GHSA-v53p-9fqp-m79j
High
—

When addressparser finds no address by its strict reading, it falls back to pulling one out of the free text with /\s*\b[^@\s]+@[^\s]+\b\s*/. That pattern backtracks quadratically, causing high resource consumption when processing a single header.

CVE-2022-42919
High
—

A vulnerability in Python 3.9.x before 3.9.16 and 3.10.x before 3.10.9 on Linux allows local privilege escalation in a non-default configuration. The multiprocessing library with the forkserver start method permits pickle deserialization from any user on the same local network of the machine.

CVE-2023-50868
High
—

A vulnerability in the DNS protocol, related to the Closest Encloser Proof aspect in RFC 5155 (when RFC 9276 guidance is skipped), allows remote attackers to cause a denial of service (DoS) by triggering excessive CPU consumption for SHA-1 computations. The attack involves sending DNSSEC responses in a random subdomain attack, known as the NSEC3 issue.

GHSA-f88m-g3jw-g9cj
High
—

Several vulnerabilities have been discovered and fixed in the upstream libvips dependency, two rated as high severity using CVSSv4. Versions of sharp prior to 0.35.0 processing untrusted input are affected.

CVE-2024-6197
High
—

libcurl's ASN1 parser has this utf8asn1str() function used for parsing an ASN.1 UTF-8 string. It can detect an invalid field and return error. Unfortunately, when doing so it also invokes `free()` on a 4 byte local stack buffer. Most modern malloc implementations detect this error and immediately abort.

CVE-2024-12797
High
—

Clients using RFC7250 Raw Public Keys (RPKs) to authenticate a server may fail to notice that the server was not authenticated, because handshakes don't abort as expected when the SSL_VERIFY_PEER verification mode is set. Impact: TLS and DTLS connections using raw public keys...

CVE-2025-48385
High
—

Git is a fast, scalable, distributed revision control system. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload.

GHSA-8h8q-6873-q5fj
High
—

Podatność dotyczy niektórych pakietów React Server Components w wersjach 19.x oraz frameworków, które używają tych pakietów, w tym Next.js w wersjach 13.x, 14.x, 15.x i 16.x korzystających z App Router. Problem jest śledzony w systemie jako CVE-2026-23870.

GHSA-p8jg-8p9f-pgmr
High
—

The faraday-http-cache library stores cached responses in JSON format by default and reads them back using JSON.load, which honors the json_class key and calls json_create on the named class. Response headers are stored verbatim in the cache entry, so a malicious origin server can return a response with a json_class key leading to unsafe deserialization.

GHSA-wq5f-xc86-pv6w
High
—

A memory-related vulnerability has been discovered and fixed in the librsvg dependency. Under certain runtime-specific conditions, it can lead to possible remote code execution (RCE) on glibc-based Linux.

CVE-2026-27601
High
—

Underscore.js to biblioteka narzędziowa dla JavaScript. W wersjach przed 1.13.8 funkcje _.flatten i _.isEqual wykorzystują rekurencję bez limitu głębokości, co w określonych warunkach może prowadzić do ataku typu Denial of Service (DoS) poprzez wywołanie przepełnienia stosu.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS