CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.04)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2023-31484
High
—

CPAN.pm before version 2.35 does not verify TLS certificates when downloading distributions over HTTPS. This allows man-in-the-middle attackers to replace downloaded packages with malicious ones.

CVE-2019-20916
High
—

The pip package before version 19.2 for Python is vulnerable to directory traversal when a URL is provided in an install command. An attacker can exploit a Content-Disposition header containing '../' in the filename to overwrite files, such as /root/.ssh/authorized_keys.

GHSA-pp92-crg2-gfv9
High
—

The vulnerability occurs when an application uses OAuth2::Client and the authorization server returns a redirect with a Location header in the form of a protocol-relative URI. In this case, OAuth2::Client#request may incorrectly resolve the redirect.

GHSA-rgj7-g3m4-5g8c
High
—

Several vulnerabilities (two rated critical under CVSSv3) have been discovered and fixed in the upstream libheif dependency. They can lead to remote code execution (RCE) on glibc-based Linux under certain conditions.

GHSA-3f6p-5ww8-9rcr
High
—

A rogue MySQL server (or a man-in-the-middle) can force mysql2 to send credentials in plaintext by requesting an auth switch to mysql_clear_password. The driver complies without verifying that TLS is active.

GHSA-2x7j-588g-ccc2
High
—

Nodemailer's address parser parses comma-separated addresses in quadratic time (O(n²)) in the number of addresses. A single crafted address string (e.g., To, Cc, Bcc, From, Reply-To) can cause significant slowdown.

CVE-2026-31802
High
—

node-tar to pełnoprawne narzędzie Tar dla Node.js. Przed wersją 7.5.11, tar (npm) może być oszukany w celu utworzenia symlinków wskazujących poza katalog ekstrakcji, co umożliwia nadpisywanie plików poza bieżącym katalogiem roboczym.

GHSA-537c-gmf6-5ccf
High
—

The wheels of pyca/cryptography include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue.

CVE-2026-23411
High
—

W jądrze Linuxa rozwiązano podatność związaną z AppArmor, która dotyczyła wyścigu między zwalnianiem danych a dostępem do nich przez system plików. Problem polegał na tym, że AppArmor umieszczał referencję do danych i_private po usunięciu oryginalnego wpisu z systemu plików.

GHSA-qpg5-fx6p-8cq3
High
—

In net-ssh, `Service::Forward#initialize` registers server-initiated auth-agent channel handlers unconditionally, so ordinary port forwarding exposes the local SSH agent.

GHSA-vxj5-fg65-x765
High
—

net-ssh's host-certificate verifier (`Net::SSH::HostKeyEntries::CertAuthority#matches_key?`) checks exactly two things when a server presents an OpenSSH certificate (`*[email protected]`) under a `@cert-authority` trusted-CA entry: (1) the cert is self-consistently signed (signature_valid).

CVE-2026-33713
High
—

n8n to otwartoźródłowa platforma do automatyzacji procesów. Przed wersjami 2.14.1, 2.13.3 i 1.123.26, uwierzytelniony użytkownik z uprawnieniami do tworzenia lub modyfikowania procesów mógł wykorzystać podatność na wstrzyknięcie SQL w węźle 'Data Table Get'.

CVE-2023-50782
High
—

W pakiecie python-cryptography znaleziono lukę, która może umożliwić zdalnemu atakującemu odszyfrowanie przechwyconych wiadomości na serwerach TLS korzystających z wymiany kluczy RSA. Może to prowadzić do ujawnienia poufnych lub wrażliwych danych.

CVE-2022-48340
High
—

W GlusterFS w wersji 11.0 występuje podatność typu use-after-free w funkcji dht_setxattr_mds_cbk w pliku dht-common.c. Może to prowadzić do nieprzewidzianego zachowania aplikacji lub awarii systemu.

CVE-2026-32887
High
—

Effect to framework TypeScript składający się z kilku pakietów, które współpracują w celu budowy aplikacji TypeScript. Przed wersją 3.20.0, używając `RpcServer.toWebHandler` (lub `HttpApp.toWebHandlerRuntime`) w handlerze trasy Next.js App Router, występowały problemy z `AsyncLocalStorage` w Node.js.

CVE-2026-25547
High
—

@isaacs/brace-expansion to hybrydowy fork TypeScript brace-expansion, który przed wersją 5.0.1 jest podatny na atak typu denial of service (DoS) spowodowany nieograniczonym rozszerzaniem zakresów klamrowych. Atakujący może dostarczyć wzór zawierający powtarzające się numeryczne zakresy klamrowe.

CVE-2026-29087
High
—

W wersjach przed 1.19.10 biblioteki @hono/node-server, podczas korzystania z serwowania statycznych plików oraz ochrony opartych na trasach, występuje niespójne dekodowanie URL, co może umożliwić dostęp do chronionych zasobów statycznych.

CVE-2026-23268
High
—

W jądrze Linuxa zidentyfikowano podatność, która pozwala nieuprzywilejowanemu lokalnemu użytkownikowi na zarządzanie politykami AppArmor. Użytkownik może załadować, zastąpić lub usunąć profile, wykorzystując atak 'confused deputy', co prowadzi do pełnego zarządzania polityką.

CVE-2026-29045
High
—

Hono to framework aplikacji webowych, który wspiera dowolne środowisko uruchomieniowe JavaScript. Przed wersją 4.12.4, używając serveStatic razem z ochronami middleware opartymi na trasach, niespójne dekodowanie URL pozwalało na dostęp do chronionych zasobów statycznych bez odpowiednich uprawnień.

CVE-2026-42035
High
—

W wersjach przed 1.15.1 i 0.31.1 w kliencie HTTP Axios występuje podatność na zanieczyszczenie prototypu, która umożliwia atakującemu wstrzykiwanie dowolnych nagłówków HTTP do wychodzących żądań. Problem ten znajduje się w adapterze HTTP (lib/adapters/http.js).

Vulnerability data from NVD (NIST) · CISA KEV · EPSS