CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.04)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2025-26519
High
—

musl libc 0.9.13 through 1.2.5 before 1.2.6 has an out-of-bounds write vulnerability when an attacker can trigger iconv conversion of untrusted EUC-KR text to UTF-8.

CVE-2024-52006
High
—

Git defines a line-based protocol used to exchange information between Git and Git credential helpers. Some ecosystems (most likely those using this protocol) may be vulnerable to attacks related to this protocol.

CVE-2023-45283
High
—

The filepath package in Go does not recognize paths with a \??\ prefix as special. On Windows, a path starting with \??\ is equivalent to a path starting with \\?\ and can be used to access arbitrary system locations.

CVE-2024-45338
High
—

An attacker can craft an input to the Parse functions that would be processed non-linearly with respect to its length, resulting in extremely slow parsing. This could cause a denial of service.

GHSA-p8jg-8p9f-pgmr
High
—

The faraday-http-cache library stores cached responses in JSON format by default and reads them back using JSON.load, which honors the json_class key and calls json_create on the named class. Response headers are stored verbatim in the cache entry, so a malicious origin server can return a response with a json_class key leading to unsafe deserialization.

GHSA-vxj5-fg65-x765
High
—

net-ssh's host-certificate verifier (`Net::SSH::HostKeyEntries::CertAuthority#matches_key?`) checks exactly two things when a server presents an OpenSSH certificate (`*[email protected]`) under a `@cert-authority` trusted-CA entry: (1) the cert is self-consistently signed (signature_valid).

GHSA-qpg5-fx6p-8cq3
High
—

In net-ssh, `Service::Forward#initialize` registers server-initiated auth-agent channel handlers unconditionally, so ordinary port forwarding exposes the local SSH agent.

CVE-2026-27578
High
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 2.10.1, 2.9.3 i 1.123.22, uwierzytelniony użytkownik z uprawnieniami do tworzenia lub modyfikowania procesów roboczych mógł wstrzykiwać dowolne skrypty do stron renderowanych przez aplikację n8n, wykorzystując różne techniki na różnych węzłach.

CVE-2026-25128
High
—

W wersjach od 5.0.9 do 5.3.3 biblioteki fast-xml-parser występuje podatność typu RangeError, która dotyczy przetwarzania encji numerycznych podczas parsowania XML z wartościami poza zakresem.

CVE-2026-33665
High
—

n8n to otwartoźródłowa platforma do automatyzacji procesów. Przed wersjami 2.4.0 i 1.121.0, gdy uwierzytelnianie LDAP było włączone, n8n automatycznie łączył tożsamość LDAP z istniejącym lokalnym kontem, jeśli atrybut e-mail LDAP odpowiadał e-mailowi lokalnego konta.

CVE-2026-23411
High
—

W jądrze Linuxa rozwiązano podatność związaną z AppArmor, która dotyczyła wyścigu między zwalnianiem danych a dostępem do nich przez system plików. Problem polegał na tym, że AppArmor umieszczał referencję do danych i_private po usunięciu oryginalnego wpisu z systemu plików.

CVE-2026-26996
High
—

minimatch to minimalne narzędzie do dopasowywania, które konwertuje wyrażenia glob na obiekty RegExp w JavaScript. Wersje 10.2.0 i wcześniejsze są podatne na atak Denial of Service (ReDoS) w przypadku, gdy wzór glob zawiera wiele kolejnych znaków * zakończonych literą, która nie występuje.

CVE-2026-33671
High
—

Picomatch to matcher glob napisany w JavaScript. Wersje przed 4.0.4, 3.0.2 i 2.3.2 są podatne na atak typu Regular Expression Denial of Service (ReDoS) podczas przetwarzania stworzonych wzorców extglob.

CVE-2026-44291
High
—

W wersjach przed 7.5.6 i 8.0.2, protobufjs używał zwykłych obiektów z dziedziczonymi prototypami do wewnętrznych tabel wyszukiwania typów. Jeśli Object.prototype został wcześniej zanieczyszczony, te tabele wyszukiwania mogły być narażone na ataki.

CVE-2026-27601
High
—

Underscore.js to biblioteka narzędziowa dla JavaScript. W wersjach przed 1.13.8 funkcje _.flatten i _.isEqual wykorzystują rekurencję bez limitu głębokości, co w określonych warunkach może prowadzić do ataku typu Denial of Service (DoS) poprzez wywołanie przepełnienia stosu.

CVE-2026-33036
High
—

fast-xml-parser umożliwia przetwarzanie XML z obiektów JS bez użycia bibliotek opartych na C/C++ lub callbacków. Wersje od 4.0.0-beta.3 do 5.5.5 zawierają podatność, która pozwala na obejście limitów rozszerzania encji przez numeryczne odniesienia znaków oraz standardowe encje XML.

GHSA-5c6j-r48x-rmvq
High
—

Pakiet npm serialize-javascript (wersje <= 7.0.2) zawiera podatność na wstrzykiwanie kodu. Jest to niekompletne rozwiązanie dla CVE-2020-7660.

CVE-2022-25883
High
—

Wersje pakietu semver przed 7.5.2 są podatne na atak Denial of Service (DoS) za pomocą wyrażeń regularnych (ReDoS) poprzez funkcję new Range, gdy nieufne dane użytkownika są dostarczane jako zakres.

CVE-2026-44290
High
—

protobufjs kompiluje definicje protobuf do funkcji JavaScript. W wersjach przed 7.5.6 i 8.0.2, protobufjs pozwalał na przechodzenie przez dziedziczone właściwości obiektów podczas stosowania opcji, co mogło prowadzić do nieprawidłowego przetwarzania opcji.

GHSA-537c-gmf6-5ccf
High
—

The wheels of pyca/cryptography include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS