CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.11.04)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2026-27601
High
—

Underscore.js to biblioteka narzędziowa dla JavaScript. W wersjach przed 1.13.8 funkcje _.flatten i _.isEqual wykorzystują rekurencję bez limitu głębokości, co w określonych warunkach może prowadzić do ataku typu Denial of Service (DoS) poprzez wywołanie przepełnienia stosu.

GHSA-5c6j-r48x-rmvq
High
—

Pakiet npm serialize-javascript (wersje <= 7.0.2) zawiera podatność na wstrzykiwanie kodu. Jest to niekompletne rozwiązanie dla CVE-2020-7660.

CVE-2026-23411
High
—

W jądrze Linuxa rozwiązano podatność związaną z AppArmor, która dotyczyła wyścigu między zwalnianiem danych a dostępem do nich przez system plików. Problem polegał na tym, że AppArmor umieszczał referencję do danych i_private po usunięciu oryginalnego wpisu z systemu plików.

CVE-2022-25883
High
—

Wersje pakietu semver przed 7.5.2 są podatne na atak Denial of Service (DoS) za pomocą wyrażeń regularnych (ReDoS) poprzez funkcję new Range, gdy nieufne dane użytkownika są dostarczane jako zakres.

CVE-2026-44290
High
—

protobufjs kompiluje definicje protobuf do funkcji JavaScript. W wersjach przed 7.5.6 i 8.0.2, protobufjs pozwalał na przechodzenie przez dziedziczone właściwości obiektów podczas stosowania opcji, co mogło prowadzić do nieprawidłowego przetwarzania opcji.

CVE-2026-44291
High
—

W wersjach przed 7.5.6 i 8.0.2, protobufjs używał zwykłych obiektów z dziedziczonymi prototypami do wewnętrznych tabel wyszukiwania typów. Jeśli Object.prototype został wcześniej zanieczyszczony, te tabele wyszukiwania mogły być narażone na ataki.

CVE-2026-33671
High
—

Picomatch to matcher glob napisany w JavaScript. Wersje przed 4.0.4, 3.0.2 i 2.3.2 są podatne na atak typu Regular Expression Denial of Service (ReDoS) podczas przetwarzania stworzonych wzorców extglob.

GHSA-vxj5-fg65-x765
High
—

net-ssh's host-certificate verifier (`Net::SSH::HostKeyEntries::CertAuthority#matches_key?`) checks exactly two things when a server presents an OpenSSH certificate (`*[email protected]`) under a `@cert-authority` trusted-CA entry: (1) the cert is self-consistently signed (signature_valid).

GHSA-qpg5-fx6p-8cq3
High
—

In net-ssh, `Service::Forward#initialize` registers server-initiated auth-agent channel handlers unconditionally, so ordinary port forwarding exposes the local SSH agent.

GHSA-prq8-7wvh-44qh
High
—

In applications using OAuth::Consumer to request OAuth 1.0 tokens, the token request helper follows 300..399 redirects returned by the OAuth server. In affected versions, OAuth::Consumer#token_request parses the raw Location header and recursively follows the redirect.

GHSA-6wmv-xq9m-fmp7
High
—

Dalli's meta protocol request formatter writes some numeric arguments into memcached commands without converting them to integers. If an application passes an attacker-controlled String to one of these arguments, CRLF sequences in it are sent to memcached as additional commands on the same connection.

GHSA-j95f-988m-3j2f
High
—

@tiptap/core contains two quadratic regular-expression denial-of-service paths in its default Markdown attribute parsers. Pandoc-style block attributes use two unanchored greedy expressions that rescan repeated __QUOTED_0 prefixes. Inline shortcode attributes use another unanchored expression, which can lead to resource exhaustion.

CVE-2019-16226
High
—

An issue was discovered in py-lmdb 0.97 where mdb_node_del does not validate a memmove in the case of an unexpected node->mn_hi, leading to an invalid write operation. This occurs when accessing a data.mdb file supplied by an attacker.

CVE-2026-3886
High
—

A vulnerability in the virtio-gpu module of the Linux kernel involves an incorrect overflow check when allocating 2D images. This flaw can lead to a buffer overflow, potentially enabling privilege escalation or system crash.

CVE-2024-45338
High
—

An attacker can craft an input to the Parse functions that would be processed non-linearly with respect to its length, resulting in extremely slow parsing. This could cause a denial of service.

CVE-2025-52565
High
—

runc is a CLI tool for spawning and running containers according to the OCI specification. Versions 1.0.0-rc3 through 1.2.7, 1.3.0-rc.1 through 1.3.2, and 1.4.0-rc.1 through 1.4.0-rc.2, due to insufficient checks when bind-mounting `/dev/pts/$n` to `/dev/console` inside the container, an attacker can...

CVE-2024-52006
High
—

Git defines a line-based protocol used to exchange information between Git and Git credential helpers. Some ecosystems (most likely those using this protocol) may be vulnerable to attacks related to this protocol.

CVE-2024-12797
High
—

Clients using RFC7250 Raw Public Keys (RPKs) to authenticate a server may fail to notice that the server was not authenticated, because handshakes don't abort as expected when the SSL_VERIFY_PEER verification mode is set. Impact: TLS and DTLS connections using raw public keys...

CVE-2025-48385
High
—

Git is a fast, scalable, distributed revision control system. When cloning a repository Git knows to optionally fetch a bundle advertised by the remote server, which allows the server-side to offload.

GHSA-f88m-g3jw-g9cj
High
—

Several vulnerabilities have been discovered and fixed in the upstream libvips dependency, two rated as high severity using CVSSv4. Versions of sharp prior to 0.35.0 processing untrusted input are affected.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS