CVE Vulnerability Catalog

Translated CVE descriptions from NVD NIST - in English

Browse vulnerabilities by package

CISA KEV catalog updated: (v2026.10.30)

Weekly CVE digest

One email a week with newly published vulnerabilities worth knowing about. No account needed.

This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.

I agree to receive the weekly CVE digest at the address above. I can withdraw this consent at any time using the link in the footer of every message.

CVE-2026-25128
High
—

W wersjach od 5.0.9 do 5.3.3 biblioteki fast-xml-parser występuje podatność typu RangeError, która dotyczy przetwarzania encji numerycznych podczas parsowania XML z wartościami poza zakresem.

CVE-2026-33036
High
—

fast-xml-parser umożliwia przetwarzanie XML z obiektów JS bez użycia bibliotek opartych na C/C++ lub callbacków. Wersje od 4.0.0-beta.3 do 5.5.5 zawierają podatność, która pozwala na obejście limitów rozszerzania encji przez numeryczne odniesienia znaków oraz standardowe encje XML.

CVE-2026-27578
High
—

n8n to platforma automatyzacji procesów roboczych typu open source. Przed wersjami 2.10.1, 2.9.3 i 1.123.22, uwierzytelniony użytkownik z uprawnieniami do tworzenia lub modyfikowania procesów roboczych mógł wstrzykiwać dowolne skrypty do stron renderowanych przez aplikację n8n, wykorzystując różne techniki na różnych węzłach.

CVE-2026-33665
High
—

n8n to otwartoźródłowa platforma do automatyzacji procesów. Przed wersjami 2.4.0 i 1.121.0, gdy uwierzytelnianie LDAP było włączone, n8n automatycznie łączył tożsamość LDAP z istniejącym lokalnym kontem, jeśli atrybut e-mail LDAP odpowiadał e-mailowi lokalnego konta.

CVE-2026-26996
High
—

minimatch to minimalne narzędzie do dopasowywania, które konwertuje wyrażenia glob na obiekty RegExp w JavaScript. Wersje 10.2.0 i wcześniejsze są podatne na atak Denial of Service (ReDoS) w przypadku, gdy wzór glob zawiera wiele kolejnych znaków * zakończonych literą, która nie występuje.

CVE-2023-50387
High
—

The KeyTrap vulnerability in the DNSSEC protocol allows a remote attacker to cause a Denial of Service (DoS) by sending DNSSEC responses containing many DNSKEY and RRSIG records. This leads to excessive CPU consumption on the DNS server, potentially causing overload.

CVE-2019-3843
High
—

A vulnerability was found in systemd where a service using the DynamicUser property can create a SUID/SGID binary that remains executable with the transient service UID/GID even after the service terminates. A local attacker could exploit this to access resources owned by a potentially different UID/GID.

CVE-2020-16156
High
—

Vulnerability in CPAN 2.28 allows signature verification bypass. An attacker can supply unauthorized code that is treated as properly signed.

GHSA-v53p-9fqp-m79j
High
—

When addressparser finds no address by its strict reading, it falls back to pulling one out of the free text with /\s*\b[^@\s]+@[^\s]+\b\s*/. That pattern backtracks quadratically, causing high resource consumption when processing a single header.

CVE-2019-20916
High
—

The pip package before version 19.2 for Python is vulnerable to directory traversal when a URL is provided in an install command. An attacker can exploit a Content-Disposition header containing '../' in the filename to overwrite files, such as /root/.ssh/authorized_keys.

CVE-2023-31484
High
—

CPAN.pm before version 2.35 does not verify TLS certificates when downloading distributions over HTTPS. This allows man-in-the-middle attackers to replace downloaded packages with malicious ones.

CVE-2024-56406
High
—

A heap buffer overflow vulnerability was discovered in Perl. Affected versions include release branches 5.34, 5.36, 5.38, and 5.40, as well as development versions from 5.33.1 through 5.41.10. When non-ASCII bytes are present in the left-hand side of the `tr` operator, `S_do_trans_invmap` can overflow the buffer.

CVE-2023-47038
High
—

A vulnerability in Perl 5.30.0 through 5.38.0 allows a heap buffer overflow when compiling a crafted regular expression. An attacker can exploit this to cause a controlled buffer overflow.

CVE-2022-42919
High
—

A vulnerability in Python 3.9.x before 3.9.16 and 3.10.x before 3.10.9 on Linux allows local privilege escalation in a non-default configuration. The multiprocessing library with the forkserver start method permits pickle deserialization from any user on the same local network of the machine.

GHSA-prq8-7wvh-44qh
High
—

In applications using OAuth::Consumer to request OAuth 1.0 tokens, the token request helper follows 300..399 redirects returned by the OAuth server. In affected versions, OAuth::Consumer#token_request parses the raw Location header and recursively follows the redirect.

CVE-2026-36849
High
—

A vulnerability in the libtiff library related to handling the SamplesPerPixel tag allows an attacker to cause a denial of service (DoS). Package updates are available for Amazon Linux 2023 that fix this issue.

GHSA-m64x-33q8-m5h7
High
—

This is a residual of GHSA-g5vv-9gxw-82hx / CVE-2026-87819. The 3.1.60 fix made Actor._from_string regex-free, but parse_actor_and_date still runs _re_actor_epoch on the same author/committer/tagger line one step earlier. That pattern backtracks quadratically when the trailing epo...

GHSA-2x7j-588g-ccc2
High
—

Nodemailer's address parser parses comma-separated addresses in quadratic time (O(n²)) in the number of addresses. A single crafted address string (e.g., To, Cc, Bcc, From, Reply-To) can cause significant slowdown.

GHSA-3f6p-5ww8-9rcr
High
—

A rogue MySQL server (or a man-in-the-middle) can force mysql2 to send credentials in plaintext by requesting an auth switch to mysql_clear_password. The driver complies without verifying that TLS is active.

GHSA-rgj7-g3m4-5g8c
High
—

Several vulnerabilities (two rated critical under CVSSv3) have been discovered and fixed in the upstream libheif dependency. They can lead to remote code execution (RCE) on glibc-based Linux under certain conditions.

Vulnerability data from NVD (NIST) · CISA KEV · EPSS