CVE Vulnerability Catalog
Translated CVE descriptions from NVD NIST - in English
Browse vulnerabilities by packageCISA KEV catalog updated: (v2026.11.04)
Weekly CVE digest
One email a week with newly published vulnerabilities worth knowing about. No account needed.
This digest covers new vulnerabilities in general, not your servers. If you want to know which of them actually run in your infrastructure, that is what Secvalis does: it scans your machines and reports only what concerns them.
In Net::OAuth for Perl before version 0.33, the sender can choose the signature algorithm used for verification. The signature_method parameter is required on every request, so the verifying party cannot pin the method. If a message names HMAC-SHA1 or HMAC-SHA256, the key is derived from consumer_secret and token_secret rather than from the provider's key. A provider using RSA-SHA1 holds only the consumer public key, and RFC 5849 does not use consumer_secret for that method, so the required parameter is filled with a placeholder. A client that names HMAC-SHA1 instead has its signature checked against that placeholder, so a guessable one is enough to forge requests for any consumer key and token.
The ISO-2022 encoding module used a stack buffer sized to MB_LEN_MAX (6 bytes) for intermediate character output. Some ISO-2022 variants can require up to 10 bytes per character, in which case conversions can trigger a stack buffer overflow of up to four bytes. An application that uses iconv(3) to convert untrusted input to or from one of the affected encodings may be vulnerable to buffer overflows if it uses one of the affected encoding modules.
Several encoding modules, including HZ, UTF-7, VIQR, and ZW, did not properly check the size of the caller-supplied output buffer before writing converted characters. An application that uses iconv(3) to convert untrusted input to or from one of the affected encodings may be vulnerable to buffer overflows if it uses one of the affected encoding modules.
The Broken Link Checker WordPress plugin before 2.4.12 does not limit which query variables it accepts from user input on sites using plain permalinks, allowing unauthenticated users to overwrite arbitrary PHP global variables, and to execute arbitrary code on the server when a classic (non-block) editor is active.
The TrueBooker WordPress plugin before 1.2.7 lacks proper authorization checks in some AJAX actions, allowing unauthenticated users to change the email address of arbitrary users, including administrators, and subsequently take over their account via the password reset flow.
The W3 Total Cache WordPress plugin before 2.10.5 does not properly validate the request path used to build cache file names, allowing unauthenticated attackers to write a file into any existing directory on the server, inside or outside the web root, overwriting whatever occupies the target name. On Apache, the same flaw overwrites the site's .htaccess files, which breaks the site and can strip hardening rules that other security measures rely on.
The TabaPay Gateway WordPress plugin through 1.4.0 does not validate the payment callback before establishing a session for the account associated with the referenced order, allowing unauthenticated attackers to log in as any registered user, including an administrator.
A flaw has been found in Comfast CF-N1-S 2.6.0.1, affecting the function get_para_from_uri in /cgi-bin/mbox-config. Manipulation of width/height arguments causes stack-based buffer overflow. The attack can be initiated remotely.
A security vulnerability has been detected in UTT HiPER 1250GW up to 3.2.7-210907-180535, affecting the strcpy function in /goform/aspApBasicConfigUrcp. Manipulation of pvid leads to stack-based buffer overflow. Remote attack is possible and exploit is public.
A weakness has been identified in UTT HiPER 1200GW up to 2.5.3-170306, affecting the strcpy function in /goform/formGroupConfig. Manipulation of timestart leads to stack-based buffer overflow. Remote attack is possible and exploit is public.
A vulnerability has been identified in armeria-xds versions prior to 1.41.0, where xDS upstream TLS peer verification may be silently disabled, allowing man-in-the-middle attacks against xDS-managed upstream connections.
A weakness has been identified in TRENDnet TEW-823DRU 1.1.02b01, affecting the strcpy function in /cgi-bin/wan.cgi. Manipulation of wan_l2tp_password leads to stack-based buffer overflow. Remote attack is possible and exploit is public.
A Critical Stored XSS, Privilege Escalation, and Security Misconfiguration vulnerability in Confluence Data Center and Server allows an unauthenticated attacker to execute arbitrary HTML or JavaScript in a victim's browser, perform actions as a higher-privileged user, and exploit security best-practice oversights.
Buffer overflow in Dawn in Google Chrome on Android prior to 151.0.7922.169. A remote attacker can exploit a crafted HTML page to execute arbitrary code outside the sandbox.
Inappropriate implementation in Media in Google Chrome on Mac prior to 151.0.7922.169. A remote attacker can exploit a crafted HTML page to execute arbitrary code outside the sandbox.
Vulnerability in Oracle Fusion Middleware Helidon (Imperative Web Server component) affects versions 3.0.0-3.2.19 and 4.0.0-4.5.2. Easily exploitable flaw allows unauthenticated attacker with network access via HTTP to perform unauthorized creation, deletion, or modification of data, unauthorized read access to a subset of data, and cause partial denial of service. Attacks may impact additional products (scope change). CVSS score 9.9.
Vulnerability in Oracle Fusion Middleware Helidon (Imperative Web Server) versions 1.0.0-1.4.18. Allows unauthenticated attacker via HTTP to perform unauthorized creation, deletion, or modification of data and access data. CVSS 9.1.
Vulnerability in Oracle Fusion Middleware Helidon (Imperative Web Server) versions 1.0.0-1.4.18. Allows unauthenticated attacker via HTTP to perform unauthorized creation, deletion, or modification of data and access data. CVSS 9.1.
Vulnerability in Oracle Fusion Middleware Helidon (Imperative Web Server component) affects versions 1.0.0-1.4.19. Easily exploitable flaw allows unauthenticated attacker with network access via HTTP to take over Helidon. CVSS score 9.8.
Vulnerability in Oracle Fusion Middleware Helidon (Imperative Web Server) versions 4.0.0-4.4.1. Allows unauthenticated attacker via HTTP to perform unauthorized creation, deletion, or modification of data, access data, and cause partial denial of service. CVSS 9.4.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

