Suricata vulnerabilities
56 known CVE vulnerabilities in Suricata, translated and rated.
- CVE-2025-64330High
In Suricata prior to versions 7.0.13 and 8.0.2, a single byte read heap overflow when logging the verdict in eve.alert and eve.drop records can lead to crashes. This requires the per packet alert queue to be filled with alerts and then followed by a pass rule.
- CVE-2025-59150High
Suricata version 8.0.0 has a bug in the usage of the tls.subjectaltname keyword that can lead to a segmentation fault when the decoded subjectaltname contains a NULL byte. This issue is fixed in version 8.0.1. A workaround is to disable rules using the tls.subjectaltname keyword.
- CVE-2025-59149Medium
In Suricata version 8.0.0, rules using the keyword ldap.responses.attribute_type (which is long) with transforms can lead to a stack buffer overflow during startup or rule reload. This issue is fixed in version 8.0.1. Workaround is to disable rules with this keyword and transforms.
- CVE-2025-59148High
Suricata is a network IDS, IPS and NSM engine developed by the OISF (Open Information Security Foundation) and the Suricata community. Versions 8.0.0 and below incorrectly handle the entropy keyword when not anchored to a "sticky" buffer, which can lead to a segmentation fault. This issue is fixed in version 8.0.1. To workaround this issue, users can disable rules using the entropy keyword, or validate they are anchored to a sticky buffer.
- CVE-2025-59147High
Suricata versions 7.0.11 and below, as well as 8.0.0, are vulnerable to detection bypass when crafted traffic sends multiple SYN packets with different sequence numbers within the same flow tuple, which can cause Suricata to fail to pick up the TCP session. In IDS mode this can lead to a detection and logging bypass. In IPS mode this will lead to the flow getting blocked.
- CVE-2023-35852High
In Suricata before version 6.0.13, an adversary controlling an external source of rules may exploit a dataset filename to trigger directory traversal, leading to write access to the local filesystem. This issue is addressed in version 6.0.13 by requiring the use of allow-absolute-filenames and allow-write options in the datasets rules configuration section.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

