Roo Code vulnerabilities
15 known CVE vulnerabilities in Roo Code, translated and rated.
- CVE-2025-58371Critical
Roo Code versions 3.26.6 and below use unsanitized pull request metadata in a privileged context in a GitHub workflow, allowing an attacker to achieve Remote Code Execution (RCE) on the Actions runner. The workflow runs with broad permissions and access to repository secrets, potentially leading to complete compromise of the repository and its associated services.
- CVE-2026-110206High
Roo Code through 3.54.0 contains a command approval bypass vulnerability in parseCommandLine() that allows attackers to auto-approve arbitrary shell commands by placing a command substitution in command position. Attackers using indirect prompt injection can submit commands like $(echo touch /tmp/x) that pass the echo allowlist check, causing the shell to execute the output without user approval.
- CVE-2026-110205High
Roo Code through 3.54.0 contains a command approval bypass vulnerability in parseCommandLine() that discards command substitutions placed next to * or ? glob characters. Attackers using indirect prompt injection can craft commands like echo *$(...) that match allowlisted prefixes, executing denied commands without user approval when auto-approval is enabled.
- CVE-2026-110204High
Roo Code through 3.54.0 contains a command approval bypass vulnerability that allows attackers to run denied shell commands because parseCommandLine() treats ${ command; } substitutions as parameter expansions. Attackers using indirect prompt injection can embed denied commands inside an allowlisted command like echo to execute them without user approval on bash 5.3+ or ksh93.
- CVE-2026-110203High
Roo Code through 3.54.0 contains a command approval bypass vulnerability that allows attackers to auto-approve denied shell commands by abusing quote-masking regex in parseCommandLine(). Attackers can use indirect prompt injection with escaped or single-quoted double quotes to hide command separators behind allowlisted prefixes like echo, executing commands without user approval.
- CVE-2026-110202High
Roo Code through 3.54.0 contains a command approval bypass vulnerability in getCommandDecision() that allows attackers to auto-approve denied shell commands by prefixing them with a bare >& redirect. Attackers using indirect prompt injection can make the allowlist match a redirect target like echo while the shell runs the denied command on the developer machine.
- CVE-2026-82537High
Roo-Code through 3.54.0 contains an auto-approve bypass vulnerability that allows attackers to execute denied shell commands by exploiting a word-boundary mismatch in comment handling between the approval gate's shell parser and bash. Attackers can craft a command string with an allowlisted word immediately followed by a hash character, separator, and denied command to pass the approval gate while bash executes the denied command with the agent's auto-execute privileges on the developer's machine.
- CVE-2026-82536High
Roo-Code through 3.54.0 contains an auto-approve bypass vulnerability in the shell command parsing logic that allows attackers to execute denied shell commands by exploiting the omission of the bash pipe operator from the command parser's operator token set. Attackers can craft a command line with an allowlisted prefix followed by the stderr-redirecting pipe operator and a denied command, causing the parser to approve the full pipeline while bash executes the denied component with the agent's auto-execute privileges on the developer's machine.
- CVE-2026-81837Medium
A flaw has been found in RooCodeInc Roo-Code up to 3.51.1. This issue affects the function path.resolve of the file src/core/tools/ApplyPatchTool.ts. This manipulation causes path traversal. It is possible to initiate the attack remotely. The exploit has been published and may be used. The vendor stated that the project is no longer supported, so this vulnerability only affects products that are no longer supported by the maintainer.
- CVE-2026-81836Low
Roo-Code up to version 3.51.1 has a vulnerability in the OAuth Callback component (src/integrations/claude-code/oauth.ts) that results in cleartext transmission of sensitive information. The attack can be performed remotely but is difficult to exploit. The project is no longer supported by the maintainer.
- CVE-2026-81835Medium
A security vulnerability has been detected in RooCodeInc Roo-Code up to 3.51.1. This affects the function fetch_instructions of the file malicious_mcp_server.py of the component MCP Integration Trust Model. The manipulation leads to code injection. The attack is possible to be carried out remotely. The exploit has been disclosed publicly and may be used. The vendor stated that the project is no longer supported, so this vulnerability only affects products that are no longer supported by the maintainer.
- CVE-2026-81834Medium
A weakness has been identified in RooCodeInc Roo-Code up to 3.51.1. Affected by this issue is the function ExecaTerminalProcess of the component README File Handler. Executing a manipulation can lead to code injection. The attack can be executed remotely. The exploit has been made available to the public and could be used for attacks. The vendor no longer supports this project.
- CVE-2026-81833Medium
A security flaw has been discovered in RooCodeInc Roo-Code up to 3.51.1. Affected by this vulnerability is the function optimizeQuery of the file src/utils/helpers.ts of the component CodeIndexManager. Performing a manipulation results in code injection. Remote exploitation of the attack is possible. The exploit has been released to the public and may be used for attacks. The vendor no longer supports this project.
- CVE-2026-63108High
Roo Code through 3.54.0 has a command injection vulnerability in the auto-approve execute feature. Attackers can bypass allowlist/denylist by nesting command substitutions inside parameter expansion defaults, allowing arbitrary command execution.
- CVE-2025-65946High
Roo Code, an AI-powered autonomous coding agent, prior to version 3.26.7 had a validation error that allowed automatic execution of commands not matching allow list prefixes. The issue is patched in version 3.26.7.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

