Moby vulnerabilities
4 known CVE vulnerabilities in Moby, translated and rated.
- CVE-2025-54410Low
Moby (Docker Engine) releases before 28.0.0 are affected by a firewalld vulnerability. When firewalld reloads, Docker fails to re-create iptables rules isolating bridge networks, allowing any container to access all ports on any other container across different bridge networks on the same host. Only containers in --internal networks remain protected.
- CVE-2026-34040High
Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows attackers to bypass authorization plugins (AuthZ). This issue has been patched in version 29.3.1.
- CVE-2026-41567High
Moby (Docker Engine) before versions 29.5.1 and v2.0.0-beta.14 has a vulnerability where the daemon uses decompression binaries from the container's filesystem when extracting archives. A malicious image can replace these binaries, leading to arbitrary code execution with full daemon privileges.
- CVE-2026-33997Medium
Moby (Docker) before version 29.3.1 has a vulnerability that allows bypassing plugin privilege validation during installation. The daemon may accept a privilege set different from the user-approved one, and for single-privilege plugins no comparison is performed.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

