CVE-2026-9059
CriticalCVSS 9.3Exploitation Probability (EPSS)
Low risk21th percentile - higher than 21% of all known CVEs
Summary
SQL Injection vulnerability in NextGEN Gallery prior to version 4.2.1. An authenticated attacker with 'NextGEN Gallery overview' capability can inject arbitrary SQL into the ORDER BY clause via the 'orderby' parameter in REST API endpoints. Root cause is insufficient sanitization in '_clean_column()' using a blacklist approach.
Risk Assessment
Risk of unauthorized database access in WordPress, potentially leading to data leakage, modification, or deletion.
Recommendation
Update NextGEN Gallery to version 4.2.1 or later. Restrict 'NextGEN Gallery overview' capability to trusted administrators only.
Other vulnerabilities in NextGEN Gallery
See all- CVE-2026-94123High
The NextGEN Gallery plugin in versions up to and including 4.5.0 contains an Arbitrary File Download vulnerability exploitable by an unauthenticated attacker. This allows downloading arbitrary files from the server.
- CVE-2026-76010High
The NextGEN Gallery plugin for WordPress (up to and including 4.4.1) is vulnerable to Remote Code Execution via the render_image function. This is due to unrestricted mass assignment of caller-supplied meta_data keys onto the image model, missing realpath containment in path construction, and a bypassable signature check on the public image delivery route. An authenticated attacker with custom-level access and above can execute code on the server.
- CVE-2026-116563Medium
The NextGEN Gallery plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 4.5.4 due to insufficient input sanitization and output escaping. This allows unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
- CVE-2026-28141High
Unauthenticated Cross Site Scripting (XSS) vulnerability in NextGEN Gallery versions up to 4.2.3. An attacker can inject malicious script without authentication.
- CVE-2026-6566Medium
The NextGEN Gallery plugin for WordPress up to version 4.2.0 has an Insecure Direct Object Reference vulnerability in the image deletion REST API. Object-level authorization is missing – only 'NextGEN Manage gallery' permissions are checked, without gallery ownership verification. An authenticated attacker with Subscriber privileges and 'NextGEN Manage gallery' capability can delete other users' images and associated files from disk.
Original NVD description (English source)
NextGEN Gallery version prior to 4.2.1 are vulnerable to authenticated SQL injection via the 'orderby' parameter on the REST API endpoints '/imagely/v1/galleries' and '/imagely/v1/albums'. The root cause is an insufficient sanitization function ('_clean_column()') in the data mapper layer that uses a character blacklist instead of a whitelist approach. This allows an authenticated attacker with the 'NextGEN Gallery overview' capability (assigned to the Administrator role by default) to inject arbitrary SQL into the 'ORDER BY' clause.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

