CVE-2026-53925
HighCVSS 7.8Exploitation Probability (EPSS)
Low risk8th percentile - higher than 8% of all known CVEs
Summary
Glances is a system monitoring tool that, from versions 4.0.8 to 4.5.5, has a vulnerability in the secure_popen() function. This function interprets redirection, pipe, and command chaining operators without validation, allowing unauthorized actions on the system.
Risk Assessment
An attacker can modify the Glances configuration file, enabling them to write arbitrary data to the filesystem and execute unauthorized commands. This poses a serious threat to the integrity and security of the system.
Recommendation
It is recommended to update Glances to version 4.5.5 or later to mitigate this vulnerability. Additionally, access to the configuration file should be restricted to prevent unauthorized modifications.
Other vulnerabilities in Glances
See all- CVE-2026-68520Medium
Glances before 4.5.6 has a vulnerability in as_dict_secure() in glances/config.py that checks only option names and exposes public_username and credentials embedded in public_api values through unauthenticated GET /api/4/config and GET /api/4/config/ip requests.
- CVE-2026-68519High
Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.6, GlancesActions.run() in glances/actions.py ignores --disable-config-exec for on-alert action commands and invokes secure_popen() with shell operators enabled, allowing configured redirection, command chaining, or pipes to execute when an alert triggers. This issue is fixed in 4.5.6.
- CVE-2026-62982High
Glances is an open-source system cross-platform monitoring tool. From 4.5.2 until 4.5.6, _sanitize_mustache_dict() in glances/actions.py skips nested list and dictionary strings such as process cmdline values, allowing pipe characters to survive chevron.render() and be executed by secure_popen() through administrator-configured action templates. This issue is fixed in 4.5.6.
- CVE-2026-68518High
Glances before version 4.5.6 has a vulnerability in _sanitize_mustache_dict() in glances/actions.py that sanitizes individual Mustache values before chevron.render(), allowing adjacent unescaped Mustache variables to reconstruct shell operators that secure_popen() executes when attacker-controlled process or container fields are rendered by an administrator-configured action template. This issue is fixed in 4.5.6.
- CVE-2026-68517Medium
Glances is an open-source system cross-platform monitoring tool. Prior to 4.5.6, the cors_origins guard in glances/outputs/glances_restful_api.py uses exact list equality instead of wildcard membership, allowing a multi-origin list containing the wildcard to retain cors_credentials and expose authenticated REST API data to an untrusted website visited by a previously authenticated user. This issue is fixed in 4.5.6.
- CVE-2026-46607High
Glances is a system monitoring tool that prior to version 4.5.5 used pickle.load() to read a version-check cache file. The lack of integrity checks and format validation before deserialization allows an attacker with access to this file to plant a malicious pickle file, leading to arbitrary code execution.
- CVE-2026-35588Medium
Prior to version 4.5.4, Glances' Cassandra export module interpolates keyspace, table, and replication_factor configuration values directly into CQL statements without validation. A user with write access to glances.conf can redirect all monitoring data to an attacker-controlled Cassandra keyspace.
- CVE-2026-35587High
Glances (an open-source system monitoring tool) prior to version 4.5.4 contains a Server-Side Request Forgery (SSRF) vulnerability in the IP plugin due to improper validation of the public_api configuration parameter. The value of public_api is used directly in outbound HTTP requests without scheme restriction or hostname/IP validation. An attacker who can modify the Glances configuration can force requests to arbitrary internal or external endpoints, and when public_username and public_password are set, credentials are leaked in the Authorization: Basic header.
- CVE-2026-34839Medium
Glances prior to version 4.5.4 exposes a REST API (/api/4/*) accessible without authentication and allows cross-origin requests from any origin due to a permissive CORS policy (Access-Control-Allow-Origin: *). A malicious website can read sensitive system information from a running Glances instance in the victim's browser, leading to cross-origin data exfiltration.
- CVE-2026-33533Medium
In Glances prior to 4.5.3, the XML-RPC server sends Access-Control-Allow-Origin: * on every HTTP response and does not validate the Content-Type header. An attacker-controlled webpage can issue a CORS simple request with a valid XML-RPC payload and read the full system monitoring dataset.
Original NVD description (English source)
Glances is an open-source system cross-platform monitoring tool. From 4.0.8 until 4.5.5, the secure_popen() function in glances/secure.py interprets > (file redirection), | (pipe), and && (command chaining) operators in command strings. These operators are applied without any validation on the target file path, piped command, or chained command. When Application Monitoring Process (AMP) modules load their command or service_cmd configuration values from glances.conf, those values are passed directly to secure_popen() with no sanitization. This allows an attacker who can modify the Glances configuration file to write arbitrary content to arbitrary filesystem paths (via >), chain arbitrary commands (via &&), or pipe command output to arbitrary programs (via |). This vulnerability is fixed in 4.5.5.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

