CVE-2026-48314
MediumCVSS 6.5Exploitation Probability (EPSS)
Low risk49th percentile - higher than 49% of all known CVEs
Summary
A Path Traversal vulnerability in ColdFusion versions 2025.9, 2023.20 and earlier allows bypassing path restrictions. An attacker can gain limited read and write access to unauthorized files or directories outside intended restrictions. Exploitation does not require user interaction.
Risk Assessment
The organization is at risk of unauthorized access to sensitive configuration files or data, potentially leading to information disclosure or modification of critical assets.
Recommendation
Immediately update ColdFusion to version 2025.10 or 2023.21 (or later) as per vendor advisory. Restrict access to the ColdFusion server to trusted networks only.
Other vulnerabilities in ColdFusion
See all- CVE-2026-75994Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. The vulnerable component is restricted to an administrative network zone by default. Exploitation of this issue does not require user interaction. Scope is changed.
- CVE-2026-106624Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106622Critical
ColdFusion is affected by a Server-Side Request Forgery (SSRF) vulnerability that could result in privilege escalation. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106621Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. Exploitation does not require user interaction.
- CVE-2026-106620Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in a security feature bypass. A low-privileged attacker could bypass security measures and gain unauthorized write access. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-106619Critical
ColdFusion is affected by an Improper Input Validation vulnerability that could result in arbitrary code execution in the context of the current user. Exploitation depends on conditions beyond the attacker's control and does not require user interaction, and the scope is changed.
- CVE-2026-106612Critical
ColdFusion is affected by an Incorrect Authorization vulnerability that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-105903Critical
ColdFusion is affected by a Code Injection vulnerability (improper control of code generation) that could result in arbitrary code execution in the context of the current user. A low-privileged attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-105899Critical
ColdFusion is affected by an Unrestricted Upload of File with Dangerous Type vulnerability that could result in arbitrary code execution in the context of the current user. An attacker could exploit this vulnerability to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
- CVE-2026-75746Critical
ColdFusion is affected by an SQL Injection vulnerability that could result in arbitrary code execution in the context of the current user. An attacker with high privileges could exploit this to execute arbitrary code. Exploitation does not require user interaction and the scope is changed.
Original NVD description (English source)
ColdFusion versions 2025.9, 2023.20 and earlier are affected by an Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability that could result in a Security feature bypass. An attacker could leverage this vulnerability to gain limited read and write access to unauthorized files or directories outside the intended restrictions. Exploitation of this issue does not require user interaction.
Vulnerability data from NVD (NIST) · CISA KEV · EPSS

